Trouble running miner on Linux Mint

The technical support subforum.
Forum rules
Do you have trouble running Riecoin software? To integrate Riecoin software in your project? Not sure where to start for your next Riecoin project? Ask here!
Be sure to give details about your issues, and more importantly to have properly read the instructions! Do some investigation first, tell us what you have tried to do so far, show us your configuration files if applicable,...
Requests that show no effort from your side will get you a caution Image.
Post Reply
Sinclair-Speccy

Trouble running miner on Linux Mint

Post by Sinclair-Speccy »

Having some trouble trying to run rieMiner on my Linux machine that runs Linux Mint. Riecoin Core works just fine and installs fine however rieMiner does not. I got it from the main page that has the downloads but it ends in a weird file extension that I think is like a deb file (rieMiner0.93a2Deb64).

I have tried to execute it by making it executable with chmond -x rieMiner0.93a2Deb64 the running it with sudo ./rieMiner0.93a2Deb64 but nothing actually happens besides an error saying version `GLIBC_2.36' not found even though it is installed? I have tried it manually too by downloading it again and attempting to execute it on its own but it wants me to open it in a different program.

Trying to manually build it doesn't show much as I don't know where it puts the compiled file when I run the command to make it. I used the source code from the GitHub page
User avatar
Pttn
Forum Staff
Forum Staff
Posts: 222
Joined: 2021-02-18 21:32:13
Location: Switzerland
Miner Score: 55.676
Contact:

Re: Trouble running miner on Linux Mint

Post by Pttn »

Danged GlibC... Impossible to Static Link, and at the same time so often breaking compatibility, such that even the latest Linux Mint or Ubuntu Lts will not support a release built on Debian 12... Well, I suppose that I should rebuild the binaries using Debian 11...

That being said, you can still easily build rieMiner with the normal instructions, just tested on a Live Linux Mint 21.2,

Code: Select all

# apt update
# apt install g++ make m4 git libgmp-dev libssl-dev libcurl4-openssl-dev nlohmann-json3-dev
git clone https://github.com/Pttn/rieMiner.git
cd rieMiner
make
According to what I saw in your screenshot in Mastodon, you did the complicated procedure used to produce the binaries that are distributed such as the one that you downloaded.
Riecoin developer
Stelo.xyz pool operator
Sinclair-Speccy

Re: Trouble running miner on Linux Mint

Post by Sinclair-Speccy »

Pttn wrote: 2023-10-20 10:31:53 Danged GlibC... Impossible to Static Link, and at the same time so often breaking compatibility, such that even the latest Linux Mint or Ubuntu Lts will not support a release built on Debian 12... Well, I suppose that I should rebuild the binaries using Debian 11...

That being said, you can still easily build rieMiner with the normal instructions, just tested on a Live Linux Mint 21.2,

Code: Select all

# apt update
# apt install g++ make m4 git libgmp-dev libssl-dev libcurl4-openssl-dev nlohmann-json3-dev
git clone https://github.com/Pttn/rieMiner.git
cd rieMiner
make
According to what I saw in your screenshot in Mastodon, you did the complicated procedure used to produce the binaries that are distributed such as the one that you downloaded.
This is such a late reply but I followed the build stuff that was with it. I might need to try this eventually :P
User avatar
Pttn
Forum Staff
Forum Staff
Posts: 222
Joined: 2021-02-18 21:32:13
Location: Switzerland
Miner Score: 55.676
Contact:

Re: Trouble running miner on Linux Mint

Post by Pttn »

Well, now you could also try the Binaries again, they have been rebuilt with a previous GlibC version (the one included with Debian 11 rather than Debian 12). I think that they should work with the latest Linux Mint Lts.
Riecoin developer
Stelo.xyz pool operator
Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests